ZuluOPC

Добро пожаловать

Благодарим вам за использование наших продуктов!

Настоящее руководство предназначено для инженерно-технического персонала использующего программу ZuluOPC.

Для начинающих:

  • Если вы только начинаете работу, познакомьтесь с возможностями программы, и установкой ZuluOPC.

  • Краткое руководство рассказывает о об общих принципах работы с программой.

  • При возникновении вопросов по работе с программой ознакомьтесь с разделом Поддержка.

Опытные пользователи могут подключиться к демонстрационному OPC UA серверу, настроить связь с OPC тегами и использовать для собственных демонстраций.

Данная версия справочной системы от 14-06-2024


Введение

Назначение документа

Настоящее руководство предназначено для инженерно-технического персонала, использующего программу ZuluOPC. При написании данного справочного руководства предполагалось, что пользователь знает о форматах хранения графической информации в ЭВМ, а также владеет понятием реляционная база данных. В руководстве подробно описываются основные функции ZuluOPC.


Поддержка

При работе с программным обеспечением всегда могут возникнуть вопросы по работе системы, её использовании и настройке.

  • «Техническая поддержка»

  • «Обучающие и демонстрационные ресурсы»

  • «Обучение сотрудников»

Техническая поддержка

Для получения технической поддержки, вы можете связаться с нашими сотрудниками. Служба поддержки всегда готова помочь Вам. Контакты технической поддержки представлены на официальном сайте в разделе Контакты: https://www.politerm.com/contacts/

Также вы можете задать интересующие вас вопросы на официальном форуме https://www.politerm.com/forums/

[Предупреждение] Предупреждение

Пожалуйста, не забывайте указывать название организации, версию (Справка|О программе) и название используемого программного обеспечения, когда связываетесь с технической поддержкой!

Обучающие и демонстрационные ресурсы

Для самостоятельного изучения и на сайте представлены различные обучающие ресурсы, примеры, статьи об опыте использования:

  • Видео уроки по работе с системой: https://www.politerm.com/videos/

  • Статьи и советы: https://www.politerm.com/articles/

  • Различные примеры (макросов, sql запросов и прочее): https://www.politerm.com/samples/

Обучение сотрудников

Приглашаем специалистов, имеющих профильное образование (в зависимости от выбранного курса) пройти обучение по работе с программными продуктами. Курсы будут полезны как для начинающих пользователей, так и для специалистов, желающих повысить свои навыки владения нашими программами. Занятия проводятся квалифицированными преподавателями по методикам и материалам компании Политерм, кроме того рассматриваются прикладные задачи на исходных данных пользователей.

Целью курсов является получение минимальных знаний и базовых навыков работы в наших программных продуктах. Сокращается время на изучение системы пользователями и её внедрения в организации. На лекциях слушатели получают информацию о работе с программными продуктами, а при выполнении практических заданий, подготовленных на основе реальных прикладных задач, отрабатывают навыки работы в программе. Кроме того, полученные знания позволяют пользователям общаться «на одном языке» с консультантами ООО «Политерм» и другими ГИС специалистами.

Более подробно об обучении вы можете узнать на странице Обучение https://www.politerm.com/articles/tips/study/


Общие сведения о программе

Наименование и обозначение программы − ZuluOPC.

ZuluOPC разработано на языке программирования Microsoft Visual C++™, с использованием библиотеки с открытым исходным кодом:

  • open62541 https://open62541.org/

Состав ПО

  1. Служба ZuluOPC Service.

    Работает в фоновом режиме, поддерживая соединения с OPC серверами и получает актуальные данные.

  2. Администратор ZuluOPC.

    Служит для настройки службы и параметров подключения к OPC серверам, создания журнала записи событий.

  3. Плагин ZuluOPC.

    Служит для удобства настройки связи между объектами слоя ZuluGIS и тегами OPC сервера.


Возможности

ZuluOPC — программа, предназначенная для получения и обработки информации в режиме реального времени с приборов учета, датчиков и контроллеров, поддерживающих обмен по стандартам OPC.

ZuluOPC позволяет передавать в режиме реального времени данные с удаленных контроллеров, датчиков, приборов в созданную математическую модель сети ZuluGIS. Слой ZuluGIS может быть связан одновременно с несколькими разнотипными OPC серверами. Показания приборов, получаемые с OPC сервера представлены в программе в виде OPC тегов - узлов дерева. OPC тег можно привязать к объекту слоя ZuluGIS и указать в какие поля следует записывать информацию.

Программа ZuluOPC позволяет:

  • Получать информацию в режиме реального времени с OPC DA и OPC UA серверов и сохранять её в базу данных слоя ZuluGIS. Слой ZuluGIS может быть связан одновременно с несколькими разнотипными OPC серверами.

  • Записывать показания тегов\узлов OPC в отдельную базу данных в виде журнала событий..

  • Если показания передаются в виде массива значений, то ZuluOPC представляет каждое значение в виде дочернего узла элемента.

  • Настроить на карте связь между объектами слоя Zulu и тегами OPC сервера, используя плагин OPC.

  • Обновлять тематическую раскраску объектов Zulu при изменении значений в базе данных.

  • Вести журнала работы службы ZuluOPC (лог).


Взаимодействие с другими программами

ZuluServer, мобильное приложение ZuluGIS Mobile и ZuluGIS Online могут работать в режиме реального времени с пространственными данными.


Сведения о технических и программных средствах, обеспечивающих выполнение системы

Поддерживаемые операционные системы:

  • Windows 11, Windows 10, Windows 7, Windows 8, Windows 8.1, Windows Vista Service Pack 2, Windows XP Service Pack 3.

  • Windows Server 2008 Service Pack 2, Windows Server 2008R2 SP1, Windows Server 2012, Windows Server 2012R2, Windows Server 2016.

Требования к оборудованию:

  • Процессор: 1.6ГГц и выше.

  • Память: 2 ГБ и выше.

  • Диск: 1,5 Гб свободного места на жестком диске.

  • Видеоадаптер: с поддержкой разрешения 1280 x 1024 и полноцветного режима True Color (видеокарта, совместимая с DirectX 9 и выше).

  • Доступ к локальной сети: 100 Мбит/с для соединения с ZuluServer в локальной сети.

  • Доступ к Интернет: 100 Мбит/с для соединения с ZuluServer через Интернет.

Требования к установленному ПО:

Для использования ZuluOPC требуется:

  1. Лицензия ZuluOPC — определяет возможное количество одновременных подключений тегов\узлов OPC.

    В демонстрационном режиме ZuluOPC позволяет подключить до 10 тегов\узлов OPC. Возможное количество подключений от 2 до 65000. При необходимости большего количества подключений следует связаться с нашими специалистами.

    [Предупреждение] Предупреждение

    Демонстрационная версия программного обеспечения не может использоваться для решения коммерческих задач. Использование программного обеспечения в коммерческих целях возможно только при получении лицензии.

  2. Лицензия ZuluServer — необходима для связи со слоями расположенными на сервере геоданных, так как ZuluOPC работает только со слоями, размещенными на ZuluServer.


Ограничение использования и лицензия

Все наши программные продукты имеют ознакомительный режим. Демо-версия позволяет ознакомиться основными функциями и возможностями программного обеспечения. Она представляют из себя полную версию продукта с небольшими количественными ограничениями.

Для использования ZuluOPC требуется:

  1. Лицензия ZuluOPC — определяет возможное количество одновременных подключений тегов\узлов OPC.

    В демонстрационном режиме ZuluOPC позволяет подключить до 10 тегов\узлов OPC. Возможное количество подключений от 2 до 65000. При необходимости большего количества подключений следует связаться с нашими специалистами.

    [Предупреждение] Предупреждение

    Демонстрационная версия программного обеспечения не может использоваться для решения коммерческих задач. Использование программного обеспечения в коммерческих целях возможно только при получении лицензии.

  2. Лицензия ZuluServer — необходима для связи со слоями расположенными на сервере геоданных, так как ZuluOPC работает только со слоями, размещенными на ZuluServer.

Лицензирование программных продуктов осуществляется с использованием ключа аппаратной защиты Hasp. Без доступа к ключу все продукты работают в демонстрационном режиме. Подробнее о настройке ключа смотрите раздел «Настройка ключа HASP».


Установка и обновление

[Внимание] Внимание

ZuluOPC не входит в стандартный пакет установщика ZuluGIS или ZuluServer.

Чтобы установить ZuluOPC:

  1. Скачайте файл установки ZuluOPC в зависимости от версии ZuluServer (ZuluGIS):

    • https://politerm.com/download/?dl=zuluopc2021msi_x86– 32-бит;

    • https://politerm.com/download/?dl=zuluopc2021msi_x64 – 64-бит.

  2. Запустите файл установки, нажмите Далее и пройдите все шаги мастера установки.

    Рисунок 1. Мастер установки

  3. После завершения установки проверьте работу службы ZuluOPCService: для этого вызовите Диспетчер задач Windows и найдите там службу ZuluOPCService. Если служба отображается в списке, то все установилось правильно.

Обновление ZuluOPC

[Внимание] Внимание

ZuluOPC не включает в себя обновления для ZuluGIS или ZuluServer.

Для обновления ZuluOPC:

  1. Скачайте файл установки ZuluOPC в зависимости от используемой версии:

    • https://politerm.com/download/?dl=zuluopc2021msi_x86– 32-бит;

    • https://politerm.com/download/?dl=zuluopc2021msi_x64 – 64-бит.

  2. Запустите файл установки, нажмите Далее и пройдите все шаги мастера установки.

После обновления вы можете проверить версию установленного ПО в Администраторе ZuluOPC (выберите пункт главного меню Справка | О программе):

Версия установленного ПО

Рисунок 2. Версия установленного ПО


Краткое руководство

Демонстрационный сервер

В офисе ООО "Политерм" размещен датчик температуры и датчик влажности. Показания датчиков обрабатываются демонстрационным OPC UA сервером. Вы можете подключиться к нему в качестве примера, настроить связь с OPC тегами и использовать для собственных демонстраций.

Сервер доступен по адресу opc.tcp://195.182.154.240:4840/freeopcua/server/

Быстрый старт

Стандарт OPC разрабатывался с целью сократить затраты на создание и сопровождение приложений промышленной автоматизации. Суть OPC проста — предоставить разработчикам промышленных программ универсальный фиксированный интерфейс (то есть набор функций) обмена данными с любыми устройствами. В то же время разработчики устройств предоставляют программу, реализующую этот интерфейс (набор функций).

OPC – это набор повсеместно принятых спецификаций, предоставляющих универсальный механизм обмена данными в системах контроля и управления. ZuluOPC поддерживает следующие стандарты:

  • OPC DA (OLE for Process Control) — семейство программных технологий, предоставляющих единый интерфейс для управления объектами автоматизации и технологическими процессами. Основывается на Windows-технологиях: OLE, ActiveX, COM/DCOM.

  • OPC (Open Platform Communications) UA (Unified Architecture) — последняя по времени выпуска спецификация, которая основана не на технологии Microsoft COM, что предоставляет кросс-платформенную совместимость (за счет отказа от использования технологии COM).

OPC-сервер – программа, получающая данные во внутреннем формате устройства или системы и преобразующая эти данные в формат OPC. OPC-сервер является источником данных для OPC-клиентов, таких как ZuluOPC.

Показания датчиков\приборов, получаемые с OPC сервера представлены в программе в виде OPC тегов\узлов дерева. Один датчик может снимать несколько показаний, например температура и влажность. OPC тег можно привязать к объекту слоя ZuluGIS и указать в какие поля следует записывать информацию.

[Подсказка] Подсказка

Связать можно как серверный, так и локальный слой ZuluGIS.

Программное обеспечение состоит из службы ZuluOPC Service, Администратора ZuluOPC и плагина ZuluOPC. Служба ZuluOPC Service работает в фоновом режиме, поддерживая соединения с OPC серверами и получая данные.

Администратор ZuluOPC служит для настройки службы и параметров подключения к OPC серверам, создания журнала записи событий.

1 - слой ZuluGIS. 2 - Выбранный OPC UA сервер. 3 - Дерево тегов\узлов OPC.

Рисунок 3. Администратор OPC

Плагин OPC позволяет выделить объект на карте Zulu и связать его c тегом OPC. Для привязки к объекту слоя Zulu используется id (sys) номер объекта.

1 - Объект на карте ZuluGIS, связанный с узлом\тегом OPC. 2 - Окно плагина OPC. 3 - ID (sys) номер объекта в окне плагина. 4 - ID (sys) номер объекта на карте.

Рисунок 4. OPC Плагин

Значения OPC тегов можно наглядно отображать, создав подписи к объекту. При динамическом изменения значений, бирка может менять цвет фона.

Рисунок 5. Пример надписи

Тематическая раскраска на основе данных OPC тегов будет автоматически обновляться при изменений событий.

Получаемые данные могут сохраняться в отдельную базу данных в виде журнала событий. В журнал записывается время и показания\значения тегов.

Пример базы данных Журнал событий

Рисунок 6. Пример базы данных Журнал событий


Администратор ZuluOPC

В администраторе ZuluOPC вы можете:

  • Управлять службой ZuluOPC: запустить, перезапустить и остановить.

  • настроить параметры работы службы ZuluOPC;

  • настроить связь слоя ZuluGIS и сервера OPC;

  • добавить и удалить доступные OPC сервера;

  • добавить и настроить теги OPC, в том числе теги, содержащие массив значений;

  • Включить Журнал сообщений для просмотра лога соединений и информации о работе службы.

  • настроить ключ защиты HASP.

Утилита Администратор OPC устанавливается совместно с ZuluServer. Запустить Администратор OPC можно используя главное меню ПУСК или файл ZuluOPCAdmin.exe, из папки установки ZuluServer.

[Подсказка] Подсказка

Для удобства связи объекта на карте и узла OPC следует использовать плагин OPC.


Управление службой ZuluOPC

В диалоге Администратор ZuluOPC вы можете управлять состоянием службы ZuluOPC:

  • Запустить.

  • Перезапустить.

  • Остановить.

[Внимание] Внимание

Для управления службой необходимы права администратора!

Для выполнения необходимой операции выберите соответствующую команду главное меню Сервис:

Управление службой ZuluOPC

Рисунок 7. Управление службой ZuluOPC


Настройка параметров службы

Для настройки параметров работы службы выберите соответствующий пункт в Администраторе OPC.

Настройка параметров службы

Рисунок 8. Настройка параметров службы

Параметры работы службы ZuluOPC:

Обработка данных

  • Интервал обработки полученных данных, не менее (мс) — указывается в миллисекундах интервал для обработки данных службой.

Журнал активности службы

  • Сохранять журнал активности службы — данная опция отвечает за ведение журнала (log) активности службы. В журнал записывается служебная информация, которая может потребоваться для отладки.

  • Ограничить журнал количеством дней — указывается количество календарных дней хранения журнала активности службы.

  • Расширенный журнал (режим отладки) — включает режим подробного ведения журнала (log). Используется для отладки и поиска ошибок.

Ключ защиты

  • Производить опрос сетевого ключа - опция опроса ключа защиты HASP. Флажок обязательно должен быть установлен при использовании сетевого ключа. При использовании локального ключа, данный флажок обязательно должен быть снят. Подробнее смотрите раздел «Настройка ключа HASP».


Настройка связи со слоем Zulu

Для связи слоя ZuluGIS с OPC сервером следует его добавить в администраторе OPC, для этого:

  1. Запустите Администратор OPC.

  2. Выберите пункт Слои Zulu в левой части окна.

  3. Нажмите кнопку Добавить....

    Добавление слоя ZuluGIS в администратор OPC

    Рисунок 9. Добавление слоя ZuluGIS в администратор OPC

  4. В открывшемся окне выберите слой с которым будет устанавливаться связь.

  5. Для серверного слоя выберите способ авторизации или укажите логин и пароль для доступа.

    Рисунок 10. Параметры авторизации

  6. Нажмите кнопку Открыть для соединения со слоем. В левой части окна отобразится пункт соответствующий слою:

  7. Откроется диалог добавления OPC сервера. Далее указываются параметры в зависимости от типа сервера:

    • OPC DA

    • OPC UA

    [Подсказка] Подсказка

    Далее следует добавить OPC сервер, добавить узлы\теги и настроить обработку значений.


Добавление OPC сервера

Слой ZuluGIS может быть связан одновременно с несколькими OPC серверами. Для связи слоя ZuluGIS с сервером OPC следует:

  1. В администраторе OPC выбрать слой и нажать + рядом с ним.

  2. Выбрать пункт OPC серверы и в правой части окна нажать кнопку Добавить....

  3. Откроется диалог добавления OPC сервера. Далее указываются параметры в зависимости от типа сервера:

    • OPC DA

    • OPC UA


Добавление DA сервера

При добавлении DA сервера указываются следующие параметры:

Добавление OPC DA сервера

Рисунок 11. Добавление OPC DA сервера

Параметры хоста:

  • Локальный - выбирается в случае, когда сервер OPC установлен на одном и том же компьютере вместе с ZuluOPC.

  • Удаленный - указывается IP адрес компьютера, где установлен OPC сервер.

Параметры доступа:

  • Анонимный - используется для анонимного доступа к OPC серверу.

  • Используя логин и пароль - при использовании парольного доступа указываются данные авторизации и домена.

Сервер OPC DA можно:

  • Выбрать из установленных - список, который позволяет выбрать OPC сервер из установленных на данном компьютере.

  • Ввести ProgID сервера - указывается уникальное имя ProgID, по которому обращаются к серверу.


Добавление UA сервера

Для настройки связи с OPC UA сервером введите строку для соединения с сервером (uri) и нажмите кнопку ....

URI сервера — унифицированный идентификатор ресурса, обозначает имя и адрес ресурса в сети.

Авторизация на сервере возможна с использованием логина\пароля.

Добавление OPC UA сервера

Рисунок 12. Добавление OPC UA сервера

При добавлении OPC UA сервера указываются:

Server url | Единый указатель ресурса
Application Name | Имя приложения
Application Type | Тип приложения
Application uri | Идентификатор приложения
Product uri | Идентификатор продукта


Добавление и настройка узлов (тегов) OPC

OPC сервер предоставляет информацию с датчиков в виде тегов (узлов). Один тег может содержать несколько значений (например температура и влажность).

Для добавления и настройки тегов (узлов) определенного OPC сервера:

  1. Выберите уже добавленный OPC сервер в левой части окна.

  2. Нажмите кнопку Добавить....

    Выбор OPC сервера

    Рисунок 13. Выбор OPC сервера

  3. Откроется окно Выбор узла OPC UA сервера.

    Теги\узлы сервера представлены в виде древовидной структуры. Галочкой должны быть отмечены теги\узлы, с которыми будет работать система.

    При выделении в списке тега\узла можно увидеть его свойства.

    Выбор узла OPC UA сервера

    Рисунок 14. Выбор узла OPC UA сервера

  4. Нажмите кнопку ОК.

  5. Узлы добавятся в дерево (в список). При выделении OPC узла\тега, в правой части окна отобразятся его параметры параметры.

    Подробнее о настройке параметров OPC тега смотрите «Настройка параметров тега OPC».

    Параметры OPC тега

    Рисунок 15. Параметры OPC тега


Настройка параметров тега OPC

Выделите тег\узел OPC в дереве объектов, его параметры отобразятся в правой части окна.

Рисунок 16. Параметры OPC-тега

Параметры подключенного тега узла содержат следующие настройки:

  • Идентификатор тега OPC — уникальный номер тега\узла. Назначается системой автоматически.

  • ID объекта слоя — уникальный номер SYS (ID) объекта из слоя ZuluGIS, с который осуществляется связь. Указывается с помощью плагина OPC, выделяя объект на карте.

Получение данных:

  • Режим чтения данных:

    • Подписка на изменения — в этом случае служба будет самостоятельно следить за изменениями значений.

    • Чтение с заданным интервалом времени — данные будут запрашиваться с определённым промежутком времени, указанным в поле Интервал времени (мс).

  • Интервал времени (мс) — указывается в миллисекундах период обновления данных. Используется, когда режим чтения указан с заданным интервалом.

Обработка данных:

  • Запись значений — база данных слоя.

  • База данных — отображается база данных, в которую происходит запись.

  • Запрос — указывается запрос из выбранной базы данных.

  • Поле базы данных — поле базы данных, в которое происходит запись выбранного тега OPC.

  • Поле базы данных (дата/время) — поле базы данных, в которое происходит запись timestamp (штамп серверного времени) для данного значения тега.

  • Записывать данные при отсутствии изменений — при включении данной опции, значения будут принудительно перезаписываться, даже при отсутствии изменений.

  • Обновлять тематическую раскраску — следует ли обновлять тематическую раскраску у объекта, при изменении значения.


Тестирование настроек OPC-тега

Во время настройки вы можете протестировать получение данных с OPC-тега. Во время тестирования можно открыть окно Журнала сообщений (Сервис|Журнал сообщений), где отображается подробный лог операций.

Чтобы открыть окно теста OPC-тега:

  1. Запустите Администратор ZuluOPC.

  2. Выделите OPC-тег в дереве объектов.

  3. В правой части окна нажмите кнопку Тест....

  4. В открывшемся окне укажите параметры для теста тега и нажмите кнопку Тест.

    В нижней части окна тестирования в области ответ будут отображаться и обновляться значения тега в зависимости от указанных настроек теста.

Тестирование настроек OPC-тега

Рисунок 17. Тестирование настроек OPC-тега


Настройка тега OPC с массивом значений

Для OPC сервера типа DA вы можете работать с тегами, которые получают массив значений (в отличии от обычных тегов).

Из массива выбирается указанное пользователем количество элементов (чисел или строк) и далее каждый элемент массива представляется узлом — подтегом с его стандартными настройками. Каждый такой подтег может быть использован для привязки к объекту слоя ZuluGIS.

Значения из массива, отображаемые как подтеги OPC

Рисунок 18. Значения из массива, отображаемые как подтеги OPC

Для настройки тега с массивом значений:

  1. Выберите OPC сервер в левой части окна.

  2. Нажмите кнопку Добавить....

  3. Установите опцию Считывать свойства текущего тега для автоматического считывания свойств выбираемого тега.

  4. Выберите тег для добавления, в нижней части окна отобразятся его свойства.

  5. Для указания того, что тег содержит массив значений установите опцию Массив значений.

  6. Укажите количество значений, получаемое из массива. После этого будет создано указанное количество "подтегов" с нумерацией от 0 до n-1.

    Значения из массива, отображаемые как подтеги OPC

    Рисунок 19. Значения из массива, отображаемые как подтеги OPC

  7. Нажмите ОК для сохранения изменений.

    Указанное количество значений массива будет добавлено к выбранному тегу, в виде узлов тега. Далее вы можете переходить к настройкам узла тега и привязке их к объектам слоя ZuluGIS.

    [Подсказка] Подсказка

    Также вы можете протестировать получение данных — для этого выберите добавленный OPC-тег и нажмите кнопку Тест....

    Значения из массива, отображаемые как подтеги OPC

    Рисунок 20. Значения из массива, отображаемые как подтеги OPC


Настройка ключа HASP

Защита программного обеспечения ZuluOPC осуществляется посредством ключа защиты HASP. При использовании локального ключа защиты HASP, настройка заключается лишь в установке драйвер для USB ключа.

При использовании сетевого ключа защиты HASP обязательно следует:

  1. Проверить доступность сетевого ключа по следующей строке в любом интернет браузере http://localhost:1947/_int_/ACC_help_index.html

  2. Включить использование сетевого ключа:

    1. В Администраторе ZuluOPC выберите пункт Параметры службы.

    2. Установите галочку Производить опрос сетевого ключа.

      Настройка сетевого ключа

      Рисунок 21. Настройка сетевого ключа

    3. Выберите команду меню Файл|Сохранить.

[Примечание] Примечание

Более подробная инструкция по настройке защиты представлена в руководстве ZuluGIS, а также на нашем сайте: http://www.politerm.com/articles/features/zuluhasp/.


Просмотр журнала сообщений Администратора ZuluOPC

Для просмотра выполняемых операций в Администраторе ZuluOPC вы можете открыть Журнал сообщений. При работе с настройками OPC-сервера, тегов или во время тестирования настроек в окне будет отображаться служебная информация, которая может потребоваться для отладки.

Чтобы открыть Журнал сообщений:

  1. Запустите Администратор ZuluOPC.

  2. Выберите команду главного меню Сервис|Журнал сообщений.

    В нижней части окна отобразится окно журнала.

Чтобы сохранить сообщения из журнала вызовите контекстное меню правой кнопкой мыши и выберите Сохранить....

Для очистки содержимого окна вызовите контекстное меню правой кнопкой мыши и выберите Очистить.

Журнал сообщений Администратор ZuluOPC

Рисунок 22. Журнал сообщений Администратор ZuluOPC


Ведение журнала работы службы

При работе службы ZuluOPC возможно ведение журнала работы службы. В журнал записывается служебная информация, которая может потребоваться для отладки. Файлы журнала сохраняются в папке установки ZuluServer в виде .txt файлов с именем ZuluOPCService_<текущая дата>.

Включить запись журнала, указать количество календарных дней хранения, а также включит подробное журналирование операций можно в Администраторе ZuluOPC.

Фрагмент файла журнала работы службы ZuluOPC:

24.07.2019 00:01:02 Layer 01471DF0: OPCUA 01544508: Write "0:2:2":
                             DB open: OK: Query open: OK: Field "opc_temp": OK
24.07.2019 00:01:02 Layer 01471DF0: OPCUA 01544508: Write "0:2:3":
                             DB open: OK: Query open: OK: Field "OPC_humidity": OK
24.07.2019 00:01:02 Layer 01471DF0: OPCUA 01544508: Write "0:2:4":
                             DB open: OK: Query open: OK: Field "opc_temp_hum": OK
24.07.2019 00:01:06 Layer 01471DF0: OPCUA 01544508: Write "0:2:2":
                             DB open: OK: Query open: OK: Field "opc_temp": OK
24.07.2019 00:01:06 Layer 01471DF0: OPCUA 01544508: Write "0:2:3":
                             DB open: OK: Query open: OK: Field "OPC_humidity": OK
24.07.2019 00:01:09 Layer 014722A0: OPCUA 026A0CF8: Changed "0:2:3"


Плагин OPC

Описание плагина

Плагин ZuluOPC служит для удобства настройки связи между объектами слоя ZuluGIS и тегами OPC сервера. С помощью плагина можно выделить объект на карте и связать его с OPC тегом. Доступен быстрый переход к связанному объекту на карте.

[Подсказка] Подсказка

В плагине ZuluOPC отображаются теги только выбранного слоя. В администраторе OPC отображаются ВСЕ добавленные слои и их теги,а также возможно настроить параметры работы службы ZuluOPC Service.


Запуск OPC плагина

Плагин OPC запускается из ZuluGIS, для этого следует выбрать команду главного меню Задачи | Поддержка OPC [image] . Окно плагина отобразится на экране.

[Подсказка] Подсказка

Вы можете добавить кнопку запуска плагина на панель инструментов. Подробнее об этом смотрите раздел ZuluGIS https://www.politerm.com/zuludoc/index.html#ui_customize_commands.html.

Окно OPC плагина

Рисунок 23. Окно OPC плагина


Выбор слоя и добавление OPC сервера

Плагин позволяет выбрать слоя из активной карты. Для выбора слоя нажмите кнопку Слой... и выберите нужный из списка.

Рисунок 24. Выбор слоя

Для добавления сервера OPC нажмите кнопку Добавить. Откроется диалог добавления OPC сервера. Далее указываются параметры в зависимости от типа сервера:

  • OPC DA

  • OPC UA

[Подсказка] Подсказка

После добавления сервера OPC можно будет добавить узлы\теги и настроить обработку значений.


Пример связи узла OPC и объекта слоя

[Предупреждение] Предупреждение

Первоначально следует создать поля в БД для записи значений OPC тегов.

Далее приведен пример связи тега\узла OPC и объекта слоя ZuluGIS. Состоит из двух шагов.

Шаг 1. Настройка плагина

  1. Открыть карту или добавить слой, с которым будет настраиваться связь.

  2. Запустить плагин ZuluOPC.

  3. Выбрать слой.

  4. Добавить OPC сервер

    Если уже был раннее добавлен, то выбрать OPC сервер из списка.

  5. Для добавления тегов выделить OPC сервер в дереве слева и нажать кнопку Добавить.... Откроется окно Выбор узла OPC UA сервера. OPC теги сервера представлены в виде древовидной структуры.

  6. Отметить галочкой теги\узлы, с которыми будет работать ZuluOPC и нажать кнопку ОК.

    [Примечание] Примечание

    При выделении в списке тега\узла можно увидеть его свойства.

    Выбор узла OPC UA сервера

    Рисунок 25. Выбор узла OPC UA сервера

    Выбранные теги\узлы добавятся в список в левой части окна. Далее следует настроить параметры обработки данных и связать c объектом (шаг 2).

Шаг 2. Привязка тега к объекту на карте

Для привязки тега OPC к объекту ZuluGIS:

  1. Выбрать тег в дереве слева!

  2. Выделить объект на карте с помощью инструмента Выделить [image] . Объект должен замигать на карте.

  3. В плагине в строке ID объекта слоя нажать кнопку [image] . ID (sys) номер выделенного на карте объекта будет записан в поле. Таким образом связь между тегом\узлом и объектом будет установлена.

    [Подсказка] Подсказка

    При нажатии на кнопку ... объект замигает на экране.

    Удерживая клавишу Alt и нажав на кнопку ...— переход по габаритам объекта.

    Привязка тега OPC к объекту на карте ZuluGIS.

    Рисунок 26. Привязка тега OPC к объекту на карте ZuluGIS.

  4. Теперь следует настроить параметры обработки данных:

    Настройка параметров обработки данных

    Рисунок 27. Настройка параметров обработки данных

  5. В строке Режим чтения данных выбрать вариант Подписка на изменение.

  6. В строке Запрос выбрать (при наличии вариантов) запрос, в котором существуют поля для записи значения тега.

  7. Выбрать Поле базы данных, в которое будут записываться значения тега.

  8. Включить Запись данных при отсутствии изменений.

  9. При использовании тематической раскраски включить опцию Обновлять тематическую раскраску. В этом случае, при изменении значений в базе данных, тематическая раскраска объекта будет автоматически обновляться.

  10. Нажмите кнопку Сохранить и перезагрузите службу OPC для применения изменений.


Журнал событий

Введение

ZuluOPC считывает информацию с тегов\узлов OPC и сохраняет их в базу данных. Получаемые значения могут сохраняться в отдельную базу данных — журнал событий. Журнал событий — база данных, в которой хранятся показания тегов\узлов OPC. В журнал событий записывается идентификатор тега OPC, ID объекта Zulu, время и значения тегов. Включить запись журнала событий можно в Администраторе OPC.

[Подсказка] Подсказка

Для хранения базы данных журнала событий рекомендуется использовать SQL Server LocalDB, Microsoft SQL Server.

Пример базы данных Журнал событий

Рисунок 28. Пример базы данных Журнал событий


Включение записи журнала событий

Для записи журнала событий сначала следует создать базу данных для хранения журнала!

Включить ведение журнала можно в Администраторе OPC, для этого следует:

  1. В Администраторе OPC выделить нажать + рядом с названием слоя и выбрать пункт Журнал событий.

  2. Установить опцию Записывать в журнал историю значений тегов OPC серверов в правой части окна.

  3. Выбрать команду меню Файл|Сохранить.

Включение журнала событий

Рисунок 29. Включение журнала событий


Сброс настроек журнала событий

Для сброса настроек журнала событий:

  1. В Администраторе OPC выбрать пункт Журнал событий.

  2. Нажать кнопку Очистить.

    Очистка настройка журнала

    Рисунок 30. Очистка настройка журнала


Создание базы данных журнала событий

Базы данных для хранения журнала событий создаётся с помощью утилиты Администратор ZuluOPC. Для создания базы данных журнала следует:

  1. Запустить Администратор OPC.

  2. Нажать + рядом с названием слоя и выбрать пункт Журнал событий.

    Создание базы данных для записи журнала событий

    Рисунок 31. Создание базы данных для записи журнала событий

  3. Нажать кнопку Создать.... Откроется окно создания журнала историй значений.

  4. Ввести Имя создаваемой базы.

  5. Выбрать Источник данных:

    • SQL Server LocalDB - рекомендуемый вариант.

    • База данных SQLite.

    • База данных Microsoft Access.

    Создание базы для записи журнала событий.

    Рисунок 32. Создание базы для записи журнала событий.

  6. В таблице в нижней части окна значения полей будут заполнены автоматически.

    [Примечание] Примечание

    Вы можете указать свои названия полей.

  7. Нажмите кнопку ОК для создания базы.

  8. Далее для включения записи установить опцию Записывать в журнал историю значений тегов OPC серверов в правой части окна.


Контакты

Если ознакомившись с данным руководством пользователя у вас еще остались вопросы по работе с системой, или в процессе работы возникли какие либо проблемы, то свяжитесь с нашей технической поддержкой. Так же мы будем рады слышать от вас пожелания по расширению функциональности системы и предложения по доработке справки.

Прежде чем связываться с нашими специалистами, убедитесь что у вас установлена самая последняя версия программы, так как именно это первым делом спросит наша техническая поддержка. Связано это с тем, что обновления происходят регулярно, и может возникнуть такая ситуация, что ошибка уже была исправлена.

Техническая поддержка доступна по телефонам: (812)767-0352, 767-0353, 766-6728, электронной почте politerm@politerm.com и на нашем форуме: https://www.politerm.com/forums/.

Данная версия справочной системы от 14 06 2024.